Hosting Provider Outage
-
Resolved
AWS has fully recovered and all services are restored.
-
Investigating
Our hosting provider for our main website is experiencing an outage affecting transfers, purchases, and product downloading. We'll continue to update you. You can find the latest updates at the AWS status page: https://health.aws.amazon.com/health/status