Logo Verveo status page

Roblox Module Taken Offsale

  • Resolved
    We have restored the module.
  • Identified
    The Roblox appeal has been submitted.
  • Investigating
    Roblox has taken our licensing module offsale. We're using Roblox's appeal system to get it back onsale.